Setting Up A dedicated server on a virtual box.

mizzy
Private First-Class
Posts: 6
Joined: Tue 25 Feb 2014 01:10
Contact:

Setting Up A dedicated server on a virtual box.

Postby mizzy » Wed 26 Feb 2014 04:18

Well I got my server files downloaded. I got my vm running on virtual box. I set virtualbox to run a bridged connection. I set up port 10001 through 10001 to be forwarded to my vm which get its address from my router based on its mac address, as advised by some tutorials else where on this forum. But when i launch the server and then look for it in war game it doesn't show up. Even though the server seems to be running fine and it says that it has connected to the match making server I find nothing. I'm not sure where to go from here. Any advise is appreciated. Thanks in advance
~mizzy

post script: here is the link to the post that helped me through most of this viewtopic.php?f=163&t=38545 credit where credit is due

bin.zwieda
Second-Lieutenant
Posts: 761
Joined: Wed 19 Sep 2012 23:47
Contact:

Re: Setting Up A dedicated server on a virtual box.

Postby bin.zwieda » Wed 26 Feb 2014 04:46

hey, i need to go to bed...
:twisted:

do you have teamviewer?

edit: now you´re offline... hmm...

can you plz check, if others can also NOT see and/or connect to your server?
if others can, but you can´t, then maybe you´ve got that "hairpin" problem with your router...
http://www.wargame-ee.com/forum/viewtopic.php?f=163&t=39001&p=451387&hilit=hairpin#p451387

mizzy
Private First-Class
Posts: 6
Joined: Tue 25 Feb 2014 01:10
Contact:

Re: Setting Up A dedicated server on a virtual box.

Postby mizzy » Wed 26 Feb 2014 05:13

hey thanks for keeping tabs. i figured it out. turns out its important to pass both tcp and udp through you router. :lol: for whatever reason my routers default is just tcp. anyway thanks for all your help!

bin.zwieda
Second-Lieutenant
Posts: 761
Joined: Wed 19 Sep 2012 23:47
Contact:

Re: Setting Up A dedicated server on a virtual box.

Postby bin.zwieda » Wed 26 Feb 2014 18:47

you are welcome!

i´ll add a note to the thread you mentioned, to maybe make it a bit clearer, you need to activate tcp and udp.

mizzy
Private First-Class
Posts: 6
Joined: Tue 25 Feb 2014 01:10
Contact:

Re: Setting Up A dedicated server on a virtual box.

Postby mizzy » Wed 26 Feb 2014 21:17

well i thought i had it figured out.
Now the problem is i can connect and see it in the server list, but the people i play with can't see it and get the "server disconnected" error when I invite them. hmmm if it were easy i guess everybody would do it. Thanks in advance for any advice.

bin.zwieda
Second-Lieutenant
Posts: 761
Joined: Wed 19 Sep 2012 23:47
Contact:

Re: Setting Up A dedicated server on a virtual box.

Postby bin.zwieda » Wed 26 Feb 2014 21:33

tell me the command line, you use, to start the server.

then, start the server and make a screenshot of all the messages, the server tells in its console and post it here.

it might be related to that.
let´s check.

Who is online

Users browsing this forum: No registered users and 1 guest