[Bug] Laggers hanging the loading screen

naizarak
Captain
Posts: 1626
Joined: Tue 25 Dec 2012 12:53
Contact:

[Bug] Laggers hanging the loading screen

Postby naizarak » Mon 13 Jan 2014 09:03

A strange phenomena I've noticed several times(but haven't been able to artificially test), is when the loading screen will take a very long time to load, probably well in excess of 60secs.

The trend seems to be when a very laggy player, with a red bar connection, is in the server. Often times when this happens, the loading screen will seemingly hang. Sometimes it gets through to the game(by which time many players will have lost patience and disconnected), or it won't load at all and all players will get the "Your computer is too slow to play the game" message.

Would be nice if laggers didn't hang the server, or if there were a way out auto-kicking players with excessively high pings.

User avatar
KattiValk
General
Posts: 6278
Joined: Tue 19 Nov 2013 03:39
Location: Houston, Texas (CST)
Contact:

Re: [Bug] Laggers hanging the loading screen

Postby KattiValk » Mon 13 Jan 2014 09:40

The way it works is that everyone has to wait until said laggy player loads his game information or (I'm not to sure which is the case) kicks them after a time or they quit the game.

L'@nge
Warrant Officer
Posts: 417
Joined: Thu 30 Jun 2011 12:12
Contact:

Re: [Bug] Laggers hanging the loading screen

Postby L'@nge » Wed 15 Jan 2014 11:11

There is a variable LoadingTimeMax that you can change so that it will kick people who take too much time to load the game.
Image

naizarak
Captain
Posts: 1626
Joined: Tue 25 Dec 2012 12:53
Contact:

Re: [Bug] Laggers hanging the loading screen

Postby naizarak » Wed 15 Jan 2014 11:19

can you tell us what the default value is? wouldn't want to be kicking people prematurely now

EDIT: nvm, i see the value is 120. ill set it to 30 for my servers and see how this works out

bin.zwieda
Second-Lieutenant
Posts: 761
Joined: Wed 19 Sep 2012 23:47
Contact:

Re: [Bug] Laggers hanging the loading screen

Postby bin.zwieda » Sat 1 Feb 2014 16:24

naizarak wrote:can you tell us what the default value is? wouldn't want to be kicking people prematurely now

EDIT: nvm, i see the value is 120. ill set it to 30 for my servers and see how this works out


can you tell, how this 30 changed your problem?
was it the solution for it?
or maybe some other value?

naizarak
Captain
Posts: 1626
Joined: Tue 25 Dec 2012 12:53
Contact:

Re: [Bug] Laggers hanging the loading screen

Postby naizarak » Sat 1 Feb 2014 19:07

bin.zwieda wrote:
naizarak wrote:can you tell us what the default value is? wouldn't want to be kicking people prematurely now

EDIT: nvm, i see the value is 120. ill set it to 30 for my servers and see how this works out


can you tell, how this 30 changed your problem?
was it the solution for it?
or maybe some other value?


honestly i don't think it does anything. occasionally the game will still take a very long time to load, in excess of 30 seconds. also in the server screen, games in the loading phase countdown from 2:00

Who is online

Users browsing this forum: No registered users and 1 guest