The W:RD Sandbox Mod (6.0) [Automatic Installer]

Private First-Class
Posts: 9
Joined: Tue 31 Jan 2017 15:53

Re: Customization of Sandbox installer?

Postby bnsonear » Wed 15 Sep 2021 13:29

Dear W:AB Noob,

I recently made series of XML script for private small mod, based on your examples in Sandbox 6.0.
It really helped me, thank you.

As I know, the current version of WGPatcher.exe shows an error if there are too many scripts are given.
So I split the script into 15 pieces. Each of them takes 2-3 minutes to complete the task.
I tried to modify "patcher_paths.json" in SandboxMod folder, then later I tried running WGPather.exe via batch file to automate modding becasue doing the job with my fingers and waiting are really pain.

Also I edited installerConfig.wmi because I have to prevent the change of Eurocorps tooltip and have to add a Name change of a certain unit.

These changes introduced unintended errors, but I could not find the soulteion because no documentation was found for syntax and usage.

Maybe SandoxModInstall.exe delivers special parameters to WGPathcer.exe and WargameModInstaller.exe?
I believe that you as a creator may answer the question.

1. No pause screen of the console window after changing installerConfig.wmi and installerConfigTemplate.wmi.

I want to stop change of the "Infinite DLC" tooltip and want to add other Unit name change during the run.
Syntax of wmi file would not be wrong, because I get the right result.
However, modding progress & result screen (console window) is not paused anymore after finish.
It automatically closed after job is done whether any error occurs or not.
This makes me harder to find debug my newly created xml code, but I don't know what is wrong and how to make stop.

ADDED LATER: I used screen recorder, so I found a strange error message related with python. Below is the screenshot.
Sandbox Error Video_2021-09-16_143005.wmv_20210916_143429.581.jpg
Sandbox Error Video_2021-09-16_143005.wmv_20210916_143429.581.jpg (94.95 KiB) Viewed 9323 times

2. NDF_Win.dat untouched when batch script is used

When I use batch script (code at the bottom) instead of SanboxModInstall.exe, the modding result is not applied to NDF_Win.dat.
The black command-line window is generated and the modding progress is displayed naturally.
However, NDF_Win.dat remained untouched and an additional file with the name of "ndf_win_patched.dat" is generated.
Running wargame3.exe after renaming the file did not work. Modding result ass not applied on both files.
Are there any hidden parameters?

3. InstallerConfig.wmi doesn't work on linked file

Name in unites.dic in "Data\WARGAME\PC\48574\ZZ_Win.dat" was easily changed by modification of InstallerConfig.wmi.
However, Name in unites.dic in Data\WARGAME\PC\49125\49964\ZZ_Win.dat is untouchble.
If I change targetPath for the latest ZZ_Win.dat, modding program stopped with the message:
An item with the same key has already been added

Code: Select all

@echo off
echo %date% %time%
"SandboxMod\Patcher\WGPatcher.exe" apply "C:\Program Files (x86)\Steam\steamapps\common\Wargame Red Dragon\Data\WARGAME\PC\49964\NDF_Win.dat" "SandboxMod\Script Library\Lobby\MapPoints.xml" "SandboxMod\Script Library\Lobby\IncreasedIncome.xml" "SandboxMod\Script Library\Lobby\TimeOptions.xml" "SandboxMod\Script Library\Gameplay\CampaignStartingPoliticalPoints.xml" "SandboxMod\Script Library\Gameplay\PlaneAltitude.xml" "SandboxMod\Script Library\Gameplay\VehicleSpeeds_BN.xml"
echo "              "
echo %time%
timeout /T 3
echo "              "
echo "              "
echo "              "
echo %time%
"SandboxMod\Patcher\WGPatcher.exe" apply "C:\Program Files (x86)\Steam\steamapps\common\Wargame Red Dragon\Data\WARGAME\PC\49964\NDF_Win.dat" "SandboxMod\Script Library\Gameplay\AccuracyReduction.xml"
echo "              "
echo %time%
timeout /T 3
echo "              "
echo %time%
"SandboxMod\Patcher\WGPatcher.exe" apply "C:\Program Files (x86)\Steam\steamapps\common\Wargame Red Dragon\Data\WARGAME\PC\49964\NDF_Win.dat" "SandboxMod\Script Library\Gameplay\KEYreworks_1_A-10.xml" "SandboxMod\Script Library\Gameplay\KEYreworks_4_DeckBreaker_Marine_ME_MO.xml"
echo "              "
echo %time%
timeout /T 3
echo "              "
echo %time%
"SandboxMod\Patcher\WGPatcher.exe" apply "C:\Program Files (x86)\Steam\steamapps\common\Wargame Red Dragon\Data\WARGAME\PC\49964\NDF_Win.dat" "SandboxMod\Script Library\Gameplay\KEYreworks_2_Su-25X.xml" "SandboxMod\Script Library\Gameplay\KEYreworks_3_Autonomy-Optic-Size_Bonus.xml"
echo "              "
echo %date% %time%
echo "            "
echo Finished the first part of Key's Reworks during 14 mins
timeout /T 7
Last edited by bnsonear on Thu 30 Sep 2021 06:44, edited 1 time in total.

Posts: 1
Joined: Tue 21 Sep 2021 12:30

Re: The W:RD Sandbox Mod (6.0) [Automatic Installer]

Postby Woinz » Tue 21 Sep 2021 13:13

Alejandro II wrote:
Yorkiesand23 wrote:Hi

Firstly I have to say your work on this mod has kept me interested in this game for a lot longer.

I have contacted the developer of the 2005 millennium mod with the following.

"The issue I have come across when I try to play the 2005 mod with the Sandbox mod, is I get the following error message

The installer was unable to find the following content file

I have tried the Sandbox mod with the 1991 mod and both work together fine.

I hope you will work with the Sandbox mod creator to see what can be done."

Hope he does reach out for support.

Thanks, and a great mod Eugen should recruit you!!


I can play whit that mod, it just give me error when i select the option of 15 cards in the sandbox configuration but i can use the 9 cards option

I faced this problem too, now I am trying to find solutions.

Return to “Modding”

Who is online

Users browsing this forum: No registered users and 4 guests