[Outdated] Wargame modding suite | v0.8.2 Pre-Release

milton
Private First-Class
Posts: 9
Joined: Tue 15 Dec 2015 05:12
Contact:

Re: [Release] Wargame modding suite | v0.8.2 Pre-Release

Postby milton » Wed 16 Dec 2015 19:19

Nothing. No dialog opens up, no editor opens up, the same result as last time. I can open the .dat files fine but I can't edit any of them.

This is the exception I get when I try to export uncompressed content:

Code: Select all

System.IO.FileNotFoundException: Could not load file or assembly 'Ionic.Zlib, Version=1.9.1.8, Culture=neutral, PublicKeyToken=edbe51ad942a3f5c' or one of its dependencies. The system cannot find the file specified.
File name: 'Ionic.Zlib, Version=1.9.1.8, Culture=neutral, PublicKeyToken=edbe51ad942a3f5c'
   at moddingSuite.BL.Compressing.Compressor.Decomp(Byte[] input, Stream outputStream)
   at moddingSuite.BL.Compressing.Compressor.Decomp(Byte[] input)
   at moddingSuite.BL.Ndf.NdfbinReader.GetUncompressedNdfbinary(Byte[] data)

Corruption
Specialist
Posts: 14
Joined: Sun 15 Nov 2015 02:52
Contact:

Re: [Release] Wargame modding suite | v0.8.2 Pre-Release

Postby Corruption » Wed 16 Dec 2015 21:42

Hey guys is there a way to figure out what I did to crash the game and what you have to do to fix it and make it playable again? I spent hours on adjusting personnel weapon stats, ifvs, afvs, mbts, added dmrs, snipers, anti material rifles, automatic grenade launchers, got rid of balance and brought true stats and units. It worked until this afternoon after I adjusted a few stuff. I'd hate to have to start from the beginning
W Battery, Royal Canadian Artillery School, 5th Canadian Division

User avatar
The W:AB Noob
Lieutenant General
Posts: 4563
Joined: Fri 12 Jul 2013 22:29
Location: United States, Central Time Zone
Contact:

Re: [Release] Wargame modding suite | v0.8.2 Pre-Release

Postby The W:AB Noob » Thu 17 Dec 2015 00:47

milton wrote:Nothing. No dialog opens up, no editor opens up, the same result as last time. I can open the .dat files fine but I can't edit any of them.

This is the exception I get when I try to export uncompressed content:

Code: Select all

System.IO.FileNotFoundException: Could not load file or assembly 'Ionic.Zlib, Version=1.9.1.8, Culture=neutral, PublicKeyToken=edbe51ad942a3f5c' or one of its dependencies. The system cannot find the file specified.
File name: 'Ionic.Zlib, Version=1.9.1.8, Culture=neutral, PublicKeyToken=edbe51ad942a3f5c'
   at moddingSuite.BL.Compressing.Compressor.Decomp(Byte[] input, Stream outputStream)
   at moddingSuite.BL.Compressing.Compressor.Decomp(Byte[] input)
   at moddingSuite.BL.Ndf.NdfbinReader.GetUncompressedNdfbinary(Byte[] data)

Well that's easy. When you download the Modding Suite, there are 2 files: an .exe and a .dll. I emphasized in my Beginners' Guide that you need to export both files to the same location in order for it to work.

Corruption wrote:Hey guys is there a way to figure out what I did to crash the game and what you have to do to fix it and make it playable again? I spent hours on adjusting personnel weapon stats, ifvs, afvs, mbts, added dmrs, snipers, anti material rifles, automatic grenade launchers, got rid of balance and brought true stats and units. It worked until this afternoon after I adjusted a few stuff. I'd hate to have to start from the beginning

Backups. Unfortunately, there is no easy tool for figuring out what makes the game crash. After doing a couple of changes, modders save then back up the file by copying the file and renaming it to "NDF_Win - Sandbox 1.dat". Can you tell me what you did this afternoon? Maybe I can figure it out.
W:RD Sandbox Mod 5.4.2, the Final and Ultimate Patch Click -> Image

Corruption
Specialist
Posts: 14
Joined: Sun 15 Nov 2015 02:52
Contact:

Re: [Release] Wargame modding suite | v0.8.2 Pre-Release

Postby Corruption » Thu 17 Dec 2015 02:05

I tried to changed the French VLRA (i think thats what its called) truck into a VBCI Dragar variant and now it crashes. I back tracked on all my adjustments but no luck. I'll take the advice and make a copy if successful modifications for now on
W Battery, Royal Canadian Artillery School, 5th Canadian Division

User avatar
The W:AB Noob
Lieutenant General
Posts: 4563
Joined: Fri 12 Jul 2013 22:29
Location: United States, Central Time Zone
Contact:

Re: [Release] Wargame modding suite | v0.8.2 Pre-Release

Postby The W:AB Noob » Thu 17 Dec 2015 02:18

Corruption wrote:I tried to changed the French VLRA (i think thats what its called) truck into a VBCI Dragar variant and now it crashes. I back tracked on all my adjustments but no luck. I'll take the advice and make a copy if successful modifications for now on

What adjustments exactly did you make?
W:RD Sandbox Mod 5.4.2, the Final and Ultimate Patch Click -> Image

Warlordz
Private First-Class
Posts: 8
Joined: Wed 30 Nov 2016 03:33
Contact:

Re: [Release] Wargame modding suite | v0.8.2 Pre-Release

Postby Warlordz » Mon 2 Jan 2017 05:22

There's something wrong with the recent version... I think.
I can't ever save my progress with my changes to RUSE. It just says Saving Failed and thinks I started Wargame.
Either I'm lost or this is a bug, but I'll know soon enough.
Thanks.

User avatar
enohka
Second-Lieutenant
Posts: 928
Joined: Sun 21 Oct 2012 04:25
Location: HEAP
Contact:

Re: [Release] Wargame modding suite | v0.8.2 Pre-Release

Postby enohka » Tue 31 Jan 2017 21:21

Warlordz wrote:There's something wrong with the recent version... I think.
I can't ever save my progress with my changes to RUSE. It just says Saving Failed and thinks I started Wargame.
Either I'm lost or this is a bug, but I'll know soon enough.
Thanks.


This error happens usually if you have your game open while trying to edit the game files. It says wargame because the tools were initially written for Wargame, but replace Wargame with RUSE in your case :P

User avatar
krasnyii
Corporal
Posts: 41
Joined: Mon 28 Nov 2016 15:19
Contact:

Re: [Outdated] Wargame modding suite | v0.8.2 Pre-Release

Postby krasnyii » Wed 7 Nov 2018 12:16

Hi everyone.

Not sure somebody will answer in this old threat ; but let's hope.

I am trying to use the modding suite to work on .dat and .ndf files from WARGAME RD (VANILLA) on LINUX.

I am using the modding suite on WINDOWS.

The .dat files (location) doesn't diplay the names correctly using empty squares ( " ▯ " ) when I open with the modding suite.

Do you know if it's a problem due to the modding suite that can't read it correctly ?

If I modify the files, writing with right caracters (letters and numbers), and I save the file, do you think the .dat will work ?

If it's isn't clear, I put an screenshot of what I mean in attachment.

Thank you !
Attachments
questionmoddingsuite.png
questionmoddingsuite.png (101.62 KiB) Viewed 466 times
Image

yuri7086
Private
Posts: 4
Joined: Sat 23 Mar 2019 11:31
Contact:

Re: [Release] Wargame modding suite | v0.8.2 Pre-Release

Postby yuri7086 » Sat 23 Mar 2019 16:04

enohka wrote:
Warlordz wrote:There's something wrong with the recent version... I think.
I can't ever save my progress with my changes to RUSE. It just says Saving Failed and thinks I started Wargame.
Either I'm lost or this is a bug, but I'll know soon enough.
Thanks.


This error happens usually if you have your game open while trying to edit the game files. It says wargame because the tools were initially written for Wargame, but replace Wargame with RUSE in your case :P


Hi,I also meet the sample problem.....When I save my change for Wargame Red Dragon,it also says saving failed and thinks I started Wargame. But I didn't start the game before starting Modding Suite or during the process of using Modding suite. Do you know how to solve this problem? Thanks a lot~~

Return to “Modding”

Who is online

Users browsing this forum: No registered users and 2 guests