Update Mod Error

Hans Klueber
Private First-Class
Posts: 8
Joined: Tue 23 Aug 2016 15:33
Contact:

Update Mod Error

Postby Hans Klueber » Fri 12 May 2017 16:05

Error.png
Error.png (25.83 KiB) Viewed 252 times



After made mod, I generated and uploaded it. It was easy. But This Error appear when I update it. Is there any solution?

Error: could not update mod: 'cp949' codec can't decode byte 0xbf in position 2: illegal multibyte sequence

Sahnvour
Specialist
Posts: 11
Joined: Mon 10 Apr 2017 15:26
Contact:

Re: Update Mod Error

Postby Sahnvour » Fri 12 May 2017 16:43

Hello,

It seems you modified NDF files and saved them with the encoding 'cp949'. As stated in the manual, the recommended encoding is UTF-8 (without BOM). That is the one we use internally, so it should work whithout any issue.

To troubleshoot this issue, please save all the NDF files you modified in UTF-8, your favorite editor should provide an option for this. Then you should be able to update your mod.

Hans Klueber
Private First-Class
Posts: 8
Joined: Tue 23 Aug 2016 15:33
Contact:

Re: Update Mod Error

Postby Hans Klueber » Fri 12 May 2017 18:00

Sahnvour wrote:Hello,

It seems you modified NDF files and saved them with the encoding 'cp949'. As stated in the manual, the recommended encoding is UTF-8 (without BOM). That is the one we use internally, so it should work whithout any issue.

To troubleshoot this issue, please save all the NDF files you modified in UTF-8, your favorite editor should provide an option for this. Then you should be able to update your mod.



I tried this with encoding converter tools, but It still doesn't work.

Sahnvour
Specialist
Posts: 11
Joined: Mon 10 Apr 2017 15:26
Contact:

Re: Update Mod Error

Postby Sahnvour » Mon 15 May 2017 09:57

Hello,

It seems the update script is using your default local encoding when reading files, hence conflicting between cp949 and utf-8. Hopefully this will be fixed in the next update.

Who is online

Users browsing this forum: Stukoke and 2 guests