Unit Falling Back error

PanzerVillari
Specialist
Posts: 19
Joined: Wed 21 Jun 2017 23:33
Contact:

Unit Falling Back error

Postby PanzerVillari » Wed 23 Aug 2017 23:30

Hey guys,
I am currently stuck on an update on my mod. In game, none of the units can be sent or told to fall back. They get pinned down and telling them to fall back does nothing. Any help on the file location would be great.

Thanks,
PanzerVillari

Hulor
Staff Sergeant
Posts: 87
Joined: Mon 10 Apr 2017 15:25
Contact:

Re: Unit Falling Back error

Postby Hulor » Thu 24 Aug 2017 11:58

Hi,

I looked to your mod and it seems there was some unexpected behaviour after the update. Can you please clean your mod folder under Users/[yourUserName]/Saved Games/EugenSystems/SteelDivision/mod/[yourModFolder], delete all folders and files except you config.ini. Then launch an UpdateMod.bat in your mod folder under steam/steamapps/common/Steel Division/Mods/[YourModName]/, it should fix your issue.
It seems our work on splitting mods and making them more tolerable between each other have make mod update more complicated.
Sorry for the inconveinance.

PanzerVillari
Specialist
Posts: 19
Joined: Wed 21 Jun 2017 23:33
Contact:

Re: Unit Falling Back error

Postby PanzerVillari » Fri 25 Aug 2017 03:01

Thanks very much. That work! But I now have the problem when closing the game, it crashes... This is only when you exit the game.

PanzerVillari
Specialist
Posts: 19
Joined: Wed 21 Jun 2017 23:33
Contact:

Re: Unit Falling Back error

Postby PanzerVillari » Fri 25 Aug 2017 05:11

So I have fixed the crashing issue when closing the game. The problem I have now is updating it to the Steam Workshop. It says it was a successful update, but the Steam Workshop does not receive it. Any advice on fixes for my folders? Or is this a Workshop issue?

P.S. I did delete my all folders besides my "config.ini".

Hulor
Staff Sergeant
Posts: 87
Joined: Mon 10 Apr 2017 15:25
Contact:

Re: Unit Falling Back error

Postby Hulor » Fri 25 Aug 2017 10:04

Hi,

It seems your config.ini has somehow been corrupted and when you uploaded your mod steam didn't update your old mod but create a new one (http://steamcommunity.com/sharedfiles/f ... earchtext=). This is probably because your config lost its ID value (steam ID, used during upload to select if we create a new mod or update an existing one). You can fix this issue by set your ID to your previous ID value which should be 972119771 in your config.ini I think.

PanzerVillari
Specialist
Posts: 19
Joined: Wed 21 Jun 2017 23:33
Contact:

Re: Unit Falling Back error

Postby PanzerVillari » Fri 25 Aug 2017 18:47

Yes that fixed it. I changed the "Mod ID". Don't change any other ID number for everyone else.

Who is online

Users browsing this forum: No registered users and 1 guest