Linux beta bug reports

Mawww
Sergeant
Posts: 54
Joined: Thu 30 Jun 2011 13:38
Contact:

Re: Linux beta bug reports

Postby Mawww » Mon 11 Feb 2013 13:49

Hello,

We are uploading a new version, this one should fix the cursor bug in game, scrolling using borders in windowed mode, and the windows deck compatibility problem. Please note that decks created under Linux may become incorrect after this update.

Thanks for testing, I believe thanks to you we managed to raise significantly the quality of our Linux port.
Image

Mawww
Sergeant
Posts: 54
Joined: Thu 30 Jun 2011 13:38
Contact:

Re: Linux beta bug reports

Postby Mawww » Mon 11 Feb 2013 13:51

Also, If you buy the game, it will not remove your beta access, so do not worry.
Image

AKMELIUS
Private
Posts: 3
Joined: Fri 1 Feb 2013 02:12
Contact:

Re: Linux beta bug reports

Postby AKMELIUS » Mon 11 Feb 2013 15:24

I can confirm that muy Athlon x2 1045t (Six cores) works flawlessly.

f70ppy
Private First-Class
Posts: 8
Joined: Fri 1 Feb 2013 00:37
Contact:

Re: Linux beta bug reports

Postby f70ppy » Mon 11 Feb 2013 16:03

I can confirm, that the white box next to the mouse cursor is fixed, but I got a new issue.
I'm able to start the first single player mission, but the when I try to start the second one, game
chrashes at the moment I click on the 'next' button.

console:

Code: Select all

Failed to load installscript /home/sip/.local/share/Steam/SteamApps/common/Wargame European Escalation/installscript.vdf
Game update: AppID 58610 "Wargame: European Escalation", ProcID 3701, IP 0.0.0.0:0
Setting breakpad minidump AppID = 58610
Steam_SetMinidumpSteamID:  Caching Steam ID:  76561197982625080 [API loaded no]
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
Segmentation fault (core dumped)
Game removed: AppID 58610 "Wargame: European Escalation", ProcID 3702
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully


dmesg:

Code: Select all

[  139.743994] Wargame[2684]: segfault at 4 ip 0904bf8e sp bfc42f50 error 4 in Wargame[8048000+2594000]
[  192.414563] Wargame[3002]: segfault at 4 ip 0904bf8e sp bff782d0 error 4 in Wargame[8048000+2594000]
[  233.228639] Wargame[3025]: segfault at 4 ip 0904bf8e sp bfd4b320 error 4 in Wargame[8048000+2594000]
[  539.988241] Wargame[3266]: segfault at 4 ip 0904bf8e sp bf903310 error 4 in Wargame[8048000+2594000]
[  744.321060] Wargame[3299]: segfault at 4 ip 0904bf8e sp bfe24930 error 4 in Wargame[8048000+2594000]


system:
Spoiler : :

Code: Select all

Processor Information:
    Vendor:  AuthenticAMD
    Speed: 3400 Mhz
    4 logical processors
    4 physical processors
    HyperThreading:  Unsupported
    FCMOV:  Supported
    SSE2:  Supported
    SSE3:  Supported
    SSSE3:  Supported
    SSE4a:  Supported
    SSE41:  Unsupported
    SSE42:  Unsupported
   
Network Information:
    Network Speed: 
   
Operating System Version:
    Ubuntu 12.04.2 LTS (32 bit)
    Kernel Name:  Linux
    Kernel Version:  3.2.0-38-generic-pae
    X Server vendor:  The X.Org Foundation
    X Server release:  11103000
   
Video Card:
    Driver:  ATI Technologies Inc. ATI Radeon HD 5700 Series

    Driver Version:  4.2.11995 Compatibility Profile Context
    Desktop Color Depth: 24 bits per pixel
    Monitor Refresh Rate: 59 Hz
    VendorID:  0x1002
    DeviceID:  0x68b8
    Number of Monitors:  1
    Number of Logical Video Cards:  1
    Primary Display Resolution:  1920 x 1080
    Desktop Resolution: 1920 x 1080
    Primary Display Size: 20.91" x 11.77"  (23.98" diag)
                                            53.1cm x 29.9cm  (60.9cm diag)
    Primary VRAM Not Detected
   
Sound card:
    Audio device: Realtek ALC889
   
Memory:
    RAM:  4025 Mb
   
Miscellaneous:
    UI Language:  English
    LANG:  en_GB.UTF-8
    Microphone:  Not set
    Total Hard Disk Space Available:  454071 Mb
    Largest Free Hard Disk Block:  344740 Mb
   


johndrinkwater
Private First-Class
Posts: 8
Joined: Fri 1 Feb 2013 01:12
Contact:

Re: Linux beta bug reports

Postby johndrinkwater » Mon 11 Feb 2013 16:36

After one of the recent updates the game is now crashing for me as soon as I load the second mission Crossroads. I have played the mission once, but abandoned it towards the end.

Multiplayer loads ok, as does the first mission, but the second causes this segfault as soon as I press Launch:

Code: Select all

Program received signal SIGSEGV, Segmentation fault.
0x0904bf8e in ?? ()
(gdb) bt
#0  0x0904bf8e in ?? ()
#1  0x0886f93f in ?? ()
#2  0x10605564 in ?? ()
#3  0x0a854200 in ?? ()


I would provide more info but I get this message in gdb:

Code: Select all

warning: the debug information found in "/media/editing/Steam/SteamApps/common/Wargame European Escalation/Wargame.dbg" does not match "/media/editing/Steam/SteamApps/common/Wargame European Escalation/Wargame" (CRC mismatch).

Mawww
Sergeant
Posts: 54
Joined: Thu 30 Jun 2011 13:38
Contact:

Re: Linux beta bug reports

Postby Mawww » Mon 11 Feb 2013 17:15

Could you upload the core file ? I did not manage to reproduce your crashes here.
Image

Mawww
Sergeant
Posts: 54
Joined: Thu 30 Jun 2011 13:38
Contact:

Re: Linux beta bug reports

Postby Mawww » Mon 11 Feb 2013 17:26

Ok, I got an explanation for your crashes.

As you have some persistence for units between mission, we use some hidden decks to store this information. The crashs are due to decks generated by the previous linux version which used bugged deck loading/saving code. This means you have some corrupted decks in your PROFILE_LOCAL_PART.wargame file. However if you delete this file, you will end up deleting all your decks, so a better solution would be to replay (and win) the campaign mission from the first (for each operation independantly).

Could you confirm that wining the first mission fixes the second mission launch ?

Thanks.
Image

f70ppy
Private First-Class
Posts: 8
Joined: Fri 1 Feb 2013 00:37
Contact:

Re: Linux beta bug reports

Postby f70ppy » Mon 11 Feb 2013 18:03

Mawww wrote:Ok, I got an explanation for your crashes.

As you have some persistence for units between mission, we use some hidden decks to store this information. The crashs are due to decks generated by the previous linux version which used bugged deck loading/saving code. This means you have some corrupted decks in your PROFILE_LOCAL_PART.wargame file. However if you delete this file, you will end up deleting all your decks, so a better solution would be to replay (and win) the campaign mission from the first (for each operation independantly).

Could you confirm that wining the first mission fixes the second mission launch ?

Thanks.


I can confirm, that this works for me. I completed mission one and now I can start the second one. THX

dpc
Private
Posts: 3
Joined: Fri 1 Feb 2013 00:34
Contact:

Re: Linux beta bug reports

Postby dpc » Mon 11 Feb 2013 22:18

I'm also affected by the problem with loading savegames. I can play from the begining.

Today I catched a weird state. After the crossroads mission I couldn't proceed to the next mission, yet the current one was over (all units visible outro brief already said). After quiting current mission I could manually start third mission from the SOLO menu though.

Mawww
Sergeant
Posts: 54
Joined: Thu 30 Jun 2011 13:38
Contact:

Re: Linux beta bug reports

Postby Mawww » Tue 12 Feb 2013 16:16

Hello,

Today new version bring some work on the OpenGL backend. Wargame should work better (i.e. not crash) with open source drivers. Intel HD4000 for example should be supported.

Thanks for testing.
Image

Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 1 guest