[MAC] Send us your crash dumps.

Plato
Corporal
Posts: 23
Joined: Fri 10 May 2013 01:46
Contact:

Re: [MAC] Send us your crash dumps.

Postby Plato » Tue 10 Sep 2013 04:58

Yes lets get back on topic, as Plato [same name while playing EE so hello, oh and I also head up the clan "Zenos Razor" if you're interested p.m. me] it should be clear that I've gotten EE to work enough, I'm a level 89 - and therefore have played a touch more than a wee-bitskee ;) . I find EE to be one of the most enjoyable games I've ever played, though it is also one of the least stable apps [besides steam :P].

I am well aware that I necoromanced my thread & heres why: partly because I was pissed, partly because I was proving a point [we philosophy majors are a pesky bunch], but partly to archive what problems I've run into and what solutions have worked for me. At this stage I'm NOT looking for any more tech help, I will however continue to post crash reports and other tidbits for the sake of the devs. Perhaps [but unlikely] they, or some mac user, might find something useful.

To reiterate again:
1] Thank you for the sentiment angry forum mob, but as you can see from my thread I am no longer in need of help in EE.
2] As long as the devs are working on fixing AB I'm content, and am patient [& and am not tired of crushing on EE 8-) ]
3] The problem I have with AB is that it gets stuck on the loading screen, this does not generate a crash report, now I can try to generate crash logs while in the loading screen if more of them would help, but if there is any other way I can help/be useful to the devs in fixing this, I currently have the time [between jobs].

Edit: @ TheHolyGhost, thanks for the moral support, but you are miss quoting me by taking my words out of context of the entire thread, for those interested in the entire thread: http://www.wargame-ee.com/forum/viewtopic.php?f=78&t=28078. All should note that EE is working for the most part. Do not confuse EE and AB, for me EE is working and AB is not working.

-> @ TheHolyGhost delete the links where you partly quote me, rather link to the entire thread, I don't want people to be miss informed about me.

Plato
Corporal
Posts: 23
Joined: Fri 10 May 2013 01:46
Contact:

Re: [MAC] Send us your crash dumps.

Postby Plato » Tue 10 Sep 2013 06:58

Just incase it wasn't clear heres my system:


The os is 10.6.8
Model Name: MacBook Pro
Model Identifier: MacBookPro7,1
Processor Name: Intel Core 2 Duo
Processor Speed: 2.4 GHz
Number Of Processors: 1
Total Number Of Cores: 2
L2 Cache: 3 MB
Memory: 8 GB
Bus Speed: 1.07 GHz
Boot ROM Version: MBP71.0039.B0B
SMC Version (system): 1.62f7
----
Chipset Model: NVIDIA GeForce 320M
Type: GPU
Bus: PCI
VRAM (Total): 256 MB
Vendor: NVIDIA (0x10de)
Device ID: 0x08a0
Revision ID: 0x00a2
ROM Revision: 3533
----
Capacity: 750.16 GB (750,156,374,016 bytes)
Model: ST750LX003-1AC154
Revision: SM12
[this is a seagate momentus XT]


looking at other posts, the commonalities are intel core 2 duo [mostly the 2.4, but there are others], and often the nivida 320m, ive seen posted my system [often with non stock HD and upgraded ram, which is true for me as well] but with different os.

Warhead
Corporal
Posts: 48
Joined: Wed 27 Feb 2013 12:16
Contact:

Re: [MAC] Send us your crash dumps.

Postby Warhead » Tue 10 Sep 2013 09:59

Eugene - this is getting ridiculous. Sort WAB out for Mac users. How you can take 3 weeks to get this sorted is quite beyond me.

User avatar
TheHolyGhost
Corporal
Posts: 24
Joined: Wed 28 Aug 2013 04:59
Location: Portland,Or
Contact:

Re: [MAC] Send us your crash dumps.

Postby TheHolyGhost » Tue 10 Sep 2013 11:09

Plato wrote:Yes lets get back on topic, as Plato [same name while playing EE so hello, oh and I also head up the clan "Zenos Razor" if you're interested p.m. me] it should be clear that I've gotten EE to work enough, I'm a level 89 - and therefore have played a touch more than a wee-bitskee ;) . I find EE to be one of the most enjoyable games I've ever played, though it is also one of the least stable apps [besides steam :P].

I am well aware that I necoromanced my thread & heres why: partly because I was pissed, partly because I was proving a point [we philosophy majors are a pesky bunch], but partly to archive what problems I've run into and what solutions have worked for me. At this stage I'm NOT looking for any more tech help, I will however continue to post crash reports and other tidbits for the sake of the devs. Perhaps [but unlikely] they, or some mac user, might find something useful.

To reiterate again:
1] Thank you for the sentiment angry forum mob, but as you can see from my thread I am no longer in need of help in EE.
2] As long as the devs are working on fixing AB I'm content, and am patient [& and am not tired of crushing on EE 8-) ]
3] The problem I have with AB is that it gets stuck on the loading screen, this does not generate a crash report, now I can try to generate crash logs while in the loading screen if more of them would help, but if there is any other way I can help/be useful to the devs in fixing this, I currently have the time [between jobs].

Edit: @ TheHolyGhost, thanks for the moral support, but you are miss quoting me by taking my words out of context of the entire thread, for those interested in the entire thread: http://www.wargame-ee.com/forum/viewtopic.php?f=78&t=28078. All should note that EE is working for the most part. Do not confuse EE and AB, for me EE is working and AB is not working.

-> @ TheHolyGhost delete the links where you partly quote me, rather link to the entire thread, I don't want people to be miss informed about me.



Really not taking it that far out of line..
It doesnt work for me at all. Wargame:EE Crashes after every level Exit.(How did you fix yours?), Wargame:ALB wont run past loading screen
I did list the whole thread in that article

I have about the same system specs expect current OS.

It wasnt about what you said.. it was about what he said. frankly your reply doesnt matter as much
i did tell everyone to visit that forum though regardless.

I am willing to wait if i knew what was happening. We just recieve no feedback what so ever. These forums should be updating constantly. It takes two minutes at most and literally alleviates problems like this where people feel bent out of shape.

User avatar
Davimotep
Sergeant Major
Posts: 260
Joined: Tue 18 Jun 2013 09:10
Contact:

Re: [MAC] Send us your crash dumps.

Postby Davimotep » Tue 10 Sep 2013 11:32

TheHolyGhost wrote:
FLX wrote:
TheHolyGhost wrote:Look at this awesome tech support:

http://imgur.com/Z5PHXcC
Administrators are no tech support.


Dude honestly i dont care what they are.
If they work for the company they shouldnt be responding to users in such a rude way thats what it boils down to.
Edit: Volunteers work for people. They just dont get payed.

You make a game for mac.... i didnt make you do that.
The game doesnt work...
The old game Wargame:EE doesnt even work anymore..
You guys ignore them endlessly..

Out of sheer curiosity I decided to visit the Wargame:EE support thread.
That god damn games has been broken for MONTHS.

I challenge anyone on this thread to go into that tech support forum channel and find all the mac freeze errors in there look at the dates and the lack of replies and still have faith.

Any employee should at least try to be useful and maybe just maybe get someone they work for to notice the post and help, i mean maybe actually fix it?

Im sure at this point you ignore this thread unless to correct insignificant points.
I will be referencing this thread in my column article.


Hi,

If you keep on being disrespectful to moderators we will be forced to take action. Call it censorship if you like, like you said it "honestly I don't care".

These guys are giving a hand with the forum and they're doing it well. If you have a problem with the way your Tech reports are being dealt with please refer to Eugen Staff.

Now on your problem with Macs. The game doesn't work for you and I'm very sorry. Like I said before I agree that the game should be working for everyone and we're working to get there... What you don't seem to understand is that WAB (and WEE) works for a majority of Mac (and Linux) users. If you spent more time detailing what happens to you and less time threatening us we may have been able to solve it earlier. You haven't even posted your full specs... I understand that you would like to get updates everyday on what we're doing but I really can't see the point. We give you updates when we actually have something to say. You'd feel better if I answer every post you make and say "Sorry it's not working, we are trying to solve this." ?

Since we were unable so far to reproduce the bug with the macs we have here some of us mac owners brought our own macs to the office yesterday.

We only encountered problems with a ~2009 Mac Mini (2,4Ghz Dual Core, 2Go RAM, Nvidia320M). The game did crash on loading screen when we tried to use the autosettings. We managed to solve this problem and get the game to work, here are the steps.

1) Delete the Wargame 2 folder located as displayed in the screenshot. (Under Users\YOU\Library\Application Support\EugenSystems\)

Spoiler : "screenshot" :
Image


Please be careful with the folder you delete. You have another Library folder under Macinthosh HD, you shouldn't find what you're looking for here.

2) Once you have deleted this, start the game and run the autosetting (Option > Video > Autosetting).

If the game still isn't running properly, get back to me I'll have something else for you guys to try.
Image

Warhead
Corporal
Posts: 48
Joined: Wed 27 Feb 2013 12:16
Contact:

Re: [MAC] Send us your crash dumps.

Postby Warhead » Tue 10 Sep 2013 13:01

Daveimotep

Thank you for the advice, and also for the reply.

Please understand our frustration - it's a great game, and we'd like to play it without constant crashes.
Also, it's been 3 weeks, and only yesterday you guys (Eugene) experimented on some other macs. Sorry, but to me that seems a bit late... but ok, we're maybe getting there.

About your advice - it's for users with the game installed directly on the mac, right?
How do I apply it to the game played through Steam?

Thank you,
Ben (Warhead)

User avatar
Davimotep
Sergeant Major
Posts: 260
Joined: Tue 18 Jun 2013 09:10
Contact:

Re: [MAC] Send us your crash dumps.

Postby Davimotep » Tue 10 Sep 2013 13:10

Warhead wrote:Daveimotep

Thank you for the advice, and also for the reply.

Please understand our frustration - it's a great game, and we'd like to play it without constant crashes.
Also, it's been 3 weeks, and only yesterday you guys (Eugene) experimented on some other macs. Sorry, but to me that seems a bit late... but ok, we're maybe getting there.

About your advice - it's for users with the game installed directly on the mac, right?
How do I apply it to the game played through Steam?

Thank you,
Ben (Warhead)


I really understand your frustration and I can't blame you guys for loosing patience, but it'd be nicer if we could keep things civil. All we (most of us) want here is to help each other.

The process i explained works with the Steam version. This folder is a generic folder with only your savefiles, replays and settings (You will loose those in the process, if you'd like you can make a backup. I'll edit my post to add this.) The folder exists regardless of the kind of installation you have.

It works like the folder in Windows's "Saved Games" folder.
Image

Warhead
Corporal
Posts: 48
Joined: Wed 27 Feb 2013 12:16
Contact:

Re: [MAC] Send us your crash dumps.

Postby Warhead » Tue 10 Sep 2013 13:53

Dave, thanks for further response.

Unfortunately I don't have these files (or at least, can't find a way to access them).

I have Macintosh HD, then Users, but then no Admin - I have (my own name) alongside little 'house' symbol, 'Deleted Users', and Shared - none of them have a Library folder inside.

Seems like my Admin folder has been deleted. Could this be the problem?

User avatar
Davimotep
Sergeant Major
Posts: 260
Joined: Tue 18 Jun 2013 09:10
Contact:

Re: [MAC] Send us your crash dumps.

Postby Davimotep » Tue 10 Sep 2013 14:24

Warhead wrote:Dave, thanks for further response.

Unfortunately I don't have these files (or at least, can't find a way to access them).

I have Macintosh HD, then Users, but then no Admin - I have (my own name) alongside little 'house' symbol, 'Deleted Users', and Shared - none of them have a Library folder inside.

Seems like my Admin folder has been deleted. Could this be the problem?


Nope, it must be under your own name, but hidden.

Here are some steps to show hidden folders with Mac OSX.
Image

Warhead
Corporal
Posts: 48
Joined: Wed 27 Feb 2013 12:16
Contact:

Re: [MAC] Send us your crash dumps.

Postby Warhead » Tue 10 Sep 2013 15:59

Ok, I found it using the link you gave, but it hasn't resolved the issue (I've only checked via the campaign - haven't yet checked Mplayer)

Return to “Tech Support”

Who is online

Users browsing this forum: No registered users and 3 guests